404 errors due to excessive traffic

Incident Report for OpenTrainTimes

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 22:01 GMT

Monitoring

From around 0100 on Friday 14th February, a number of IP addresses on the same network were scraping thousands of pages on our site, causing 404 errors to be returned to users.

These addresses have been blocked and the website is now operating normally.
Posted Feb 14, 2025 - 10:56 GMT
This incident affected: Website (Schedule data).