Map lag

Incident Report for OpenTrainTimes

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 18:16 BST

Monitoring

Due to a server problem, maps are running up to ~1h30m behind reality. We have fixed the underlying issue and will continue to monitor until the maps are up-to-date
Posted Jul 13, 2026 - 14:56 BST
This incident affected: Website (Map data).